<!DOCTYPE html><html
lang="en-US"><head>
 <script async src="https://www.googletagmanager.com/gtag/js?id=UA-115329020-1"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-115329020-1');gtag('config','AW-787435589');</script> <meta
charset="utf-8"><meta
http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><title>RFK Human Rights Partners With Skytop Strategies - Robert F. Kennedy Human Rights</title><meta
name="description" content="The new partnership further extends RFK Human Rights’ global network, engaging a new community of business leaders on practices that prioritize the public good."><link
rel="canonical" href="https://rfkhumanrights.org/news/rfk-human-rights-partners-with-skytop-strategies"><meta
property="og:type" content="website"><meta
property="og:site_name" content="Robert F. Kennedy Human Rights"><meta
property="og:url" content="https://rfkhumanrights.org/news/rfk-human-rights-partners-with-skytop-strategies"><meta
property="og:title" content="RFK Human Rights Partners With Skytop Strategies"><meta
property="og:description" content="The new partnership further extends RFK Human Rights’ global network, engaging a new community of business leaders on practices that prioritize the public good."><meta
property="og:image" content="https://rfkhumanrights.org/assets/images/_1200x630_crop_center-center_82/rfk_program_about_rfk1.jpg"><meta
property="og:image:secure_url" content="https://rfkhumanrights.org/assets/images/_1200x630_crop_center-center_82/rfk_program_about_rfk1.jpg"><meta
property="og:image:width" content="1200"><meta
property="og:image:height" content="630"><meta
property="og:image:type" content="image/jpeg"><meta
property="og:locale" content="en_us"><meta
name="twitter:card" content="summary"><meta
name="twitter:site" content="@RFKHumanRights"><meta
name="twitter:creator" content="@RFKHumanRights"><meta
name="twitter:url" content="https://rfkhumanrights.org/news/rfk-human-rights-partners-with-skytop-strategies"><meta
name="twitter:title" content="RFK Human Rights Partners With Skytop Strategies"><meta
name="twitter:description" content="The new partnership further extends RFK Human Rights’ global network, engaging a new community of business leaders on practices that prioritize the public good."><meta
name="twitter:image" content="https://rfkhumanrights.org/assets/images/_1024x512_crop_center-center_82/rfk_program_about_rfk1.jpg"> <script type="application/ld+json">{"@context":"http://schema.org/","@type":"Organization","name":"Robert F. Kennedy Human Rights","description":"A nonprofit human rights advocacy organization that works to realize Senator Robert F. Kennedy's dream of a peaceful and just world by advancing human rights.","url":"https://rfkhumanrights.org","image":{"@type":"ImageObject","url":"https://rfkhumanrights.org/assets/images/_1200x630_crop_center-center_82/rfk_program_about_rfk1.jpg","height":630,"width":1200},"sameAs":["https://www.facebook.com/RFKHumanRights/","https://twitter.com/RFKHumanRights","https://www.instagram.com/rfkhumanrights/?hl=en","https://www.youtube.com/user/RFKcenterComm","https://www.linkedin.com/company/robert-f--kennedy-center-for-justice-and-human-rights/"]}</script> <script type="application/ld+json">{"@context":"http://schema.org/","@type":"Website","name":"Robert F. Kennedy Human Rights","description":"A nonprofit human rights advocacy organization that works to realize Senator Robert F. Kennedy's dream of a peaceful and just world by advancing human rights.","url":"https://rfkhumanrights.org","image":{"@type":"ImageObject","url":"https://rfkhumanrights.org/assets/images/_1200x630_crop_center-center_82/rfk_program_about_rfk1.jpg","height":630,"width":1200},"author":{"@type":"Organization","name":"Robert F. Kennedy Human Rights","description":"A nonprofit human rights advocacy organization that works to realize Senator Robert F. Kennedy's dream of a peaceful and just world by advancing human rights.","url":"https://rfkhumanrights.org","image":{"@type":"ImageObject","url":"https://rfkhumanrights.org/assets/images/_1200x630_crop_center-center_82/rfk_program_about_rfk1.jpg","height":630,"width":1200},"sameAs":["https://www.facebook.com/RFKHumanRights/","https://twitter.com/RFKHumanRights","https://www.instagram.com/rfkhumanrights/?hl=en","https://www.youtube.com/user/RFKcenterComm","https://www.linkedin.com/company/robert-f--kennedy-center-for-justice-and-human-rights/"]},"copyrightHolder":{"@type":"Organization","name":"Robert F. Kennedy Human Rights","description":"A nonprofit human rights advocacy organization that works to realize Senator Robert F. Kennedy's dream of a peaceful and just world by advancing human rights.","url":"https://rfkhumanrights.org","image":{"@type":"ImageObject","url":"https://rfkhumanrights.org/assets/images/_1200x630_crop_center-center_82/rfk_program_about_rfk1.jpg","height":630,"width":1200},"sameAs":["https://www.facebook.com/RFKHumanRights/","https://twitter.com/RFKHumanRights","https://www.instagram.com/rfkhumanrights/?hl=en","https://www.youtube.com/user/RFKcenterComm","https://www.linkedin.com/company/robert-f--kennedy-center-for-justice-and-human-rights/"]},"creator":{"@type":"Organization","name":"Robert F. Kennedy Human Rights","description":"A nonprofit human rights advocacy organization that works to realize Senator Robert F. Kennedy's dream of a peaceful and just world by advancing human rights.","url":"https://rfkhumanrights.org","image":{"@type":"ImageObject","url":"https://rfkhumanrights.org/assets/images/_1200x630_crop_center-center_82/rfk_program_about_rfk1.jpg","height":630,"width":1200},"sameAs":["https://www.facebook.com/RFKHumanRights/","https://twitter.com/RFKHumanRights","https://www.instagram.com/rfkhumanrights/?hl=en","https://www.youtube.com/user/RFKcenterComm","https://www.linkedin.com/company/robert-f--kennedy-center-for-justice-and-human-rights/"]},"sameAs":["https://www.facebook.com/RFKHumanRights/","https://twitter.com/RFKHumanRights","https://www.instagram.com/rfkhumanrights/?hl=en","https://www.youtube.com/user/RFKcenterComm","https://www.linkedin.com/company/robert-f--kennedy-center-for-justice-and-human-rights/"]}</script> <script type="application/ld+json">{"@context":"http://schema.org/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://rfkhumanrights.org/news/rfk-human-rights-partners-with-skytop-strategies"},"description":"The new partnership further extends RFK Human Rights\u2019 global network, engaging a new community of business leaders on practices that prioritize the public good.","image":{"@type":"ImageObject","url":"https://rfkhumanrights.org/assets/images/_1200x630_crop_center-center_82/rfk_program_about_rfk1.jpg","height":630,"width":1200},"url":"https://rfkhumanrights.org/news/rfk-human-rights-partners-with-skytop-strategies","headline":"RFK Human Rights Partners With Skytop Strategies","dateCreated":"2021-04-21T20:00:00-04:00","dateModified":"2021-04-21T20:00:00-04:00","datePublished":"2021-04-25T20:00:00-04:00","author":{"@type":"Person","givenName":"Minhee","familyName":"Cho","name":"Minhee Cho","email":"&#109;&#97;&#105;&#108;&#116;&#111;&#58;&#109;&#99;&#104;&#111;&#64;&#114;&#102;&#107;&#104;&#117;&#109;&#97;&#110;&#114;&#105;&#103;&#104;&#116;&#115;&#46;&#111;&#114;&#103;"},"creator":{"@type":"Person","givenName":"Minhee","familyName":"Cho","name":"Minhee Cho","email":"&#109;&#97;&#105;&#108;&#116;&#111;&#58;&#109;&#99;&#104;&#111;&#64;&#114;&#102;&#107;&#104;&#117;&#109;&#97;&#110;&#114;&#105;&#103;&#104;&#116;&#115;&#46;&#111;&#114;&#103;"},"publisher":{"@type":"Organization","name":"Robert F. Kennedy Human Rights","description":"A nonprofit human rights advocacy organization that works to realize Senator Robert F. Kennedy's dream of a peaceful and just world by advancing human rights.","url":"https://rfkhumanrights.org","image":{"@type":"ImageObject","url":"https://rfkhumanrights.org/assets/images/rfk_program_about_rfk1.jpg","height":3168,"width":4032},"sameAs":["https://www.facebook.com/RFKHumanRights/","https://twitter.com/RFKHumanRights","https://www.instagram.com/rfkhumanrights/?hl=en","https://www.youtube.com/user/RFKcenterComm","https://www.linkedin.com/company/robert-f--kennedy-center-for-justice-and-human-rights/"]}}</script> <meta
name="author" content="Robert F. Kennedy Human Rights"><link
rel="alternate" type="application/rss+xml" title="Robert F. Kennedy Human Rights" href="/feed.rss" /><link
rel="alternate" type="application/atom+xml" title="Robert F. Kennedy Human Rights" href="/feed.atom" /><link
rel="home" href="https://rfkhumanrights.org/"><link
rel="icon" href="/favicon.ico"><link
rel="shortcut icon" href="/favicon.ico" type="image/x-icon" /><link
rel="apple-touch-icon" href="/apple-touch-icon.png" /><link
rel="apple-touch-icon" sizes="57x57" href="/img/ico/apple-touch-icon-57x57.png" /><link
rel="apple-touch-icon" sizes="72x72" href="/img/ico/apple-touch-icon-72x72.png" /><link
rel="apple-touch-icon" sizes="76x76" href="/img/ico/apple-touch-icon-76x76.png" /><link
rel="apple-touch-icon" sizes="114x114" href="/img/ico/apple-touch-icon-114x114.png" /><link
rel="apple-touch-icon" sizes="120x120" href="/img/ico/apple-touch-icon-120x120.png" /><link
rel="apple-touch-icon" sizes="144x144" href="/img/ico/apple-touch-icon-144x144.png" /><link
rel="apple-touch-icon" sizes="152x152" href="/img/ico/apple-touch-icon-152x152.png" /><link
rel="apple-touch-icon" sizes="180x180" href="/img/ico/apple-touch-icon-180x180.png" /> <script src="https://use.typekit.net/nqq6rfu.js"></script> <script>try{Typekit.load({async:true});}catch(e){}</script> <meta
name="viewport" content="width=device-width,initial-scale=1.0"><link
rel="stylesheet" href="/css/lib/icons.css?v=20200610"><link
rel="stylesheet" href="/css/framework.css"><link
rel="stylesheet" href="/css/main.css?v=2020093002"><!--[if lt IE 9]> <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script> <script src="https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js"></script> <![endif]-->
 <script>!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');fbq('init','1045385525641704');fbq('track','PageView');</script> <noscript><img
height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1045385525641704&ev=PageView&noscript=1"
/></noscript> <script type="text/javascript">_linkedin_partner_id="499513";window._linkedin_data_partner_ids=window._linkedin_data_partner_ids||[];window._linkedin_data_partner_ids.push(_linkedin_partner_id);</script><script type="text/javascript">(function(){var s=document.getElementsByTagName("script")[0];var b=document.createElement("script");b.type="text/javascript";b.async=true;b.src="https://snap.licdn.com/li.lms-analytics/insight.min.js";s.parentNode.insertBefore(b,s);})();</script> <noscript>
<img
height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=499513&fmt=gif" />
</noscript><meta
property="mt:data" content="globals.headerCode"> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-708173138"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','AW-708173138');</script> </head><body><div
id="debug"></div><div
id="loading" class="tone-light"><div
class="ring"></div></div><div
id="search">
<a
href="#" class="close toggle-search"><i
class="icon-close"></i></a><form
action="/search" class="search-form">
<a
href="#" class="submit"><i
class="icon-search"></i></a>
<input
type="text" name="q" class="input-search" placeholder="Search"></form></div><div
id="nav" class="tone-light">
<a
href="/" class="logo" data-role="internal">
<img
src="/img/logo-rfkhr-light.png" class="light" alt="Robert F. Kennedy Human Rights">
<img
src="/img/logo-rfkhr-dark.png" class="dark" alt="Robert F. Kennedy Human Rights">
<img
src="/img/icon-rfkhr-light.png" class="light-icon" alt="Robert F. Kennedy Human Rights">
<img
src="/img/icon-rfkhr-dark.png" class="dark-icon" alt="Robert F. Kennedy Human Rights">
</a><ul
class="nav-main nav-standard clear"><li
data-section="work">
<a
href="/work" data-role="internal">Our Work</a></li><li
data-section="awards">
<a
href="/awards" data-role="internal">Awards</a></li><li
data-section="news">
<a
href="/news" data-role="internal">News</a></li><li
data-section="legacy">
<a
href="/legacy" data-role="internal">Bobby</a></li><li
data-section="about">
<a
href="/about" data-role="internal">About</a></li><li
data-section="donation">
<a
href=https://rfkhumanrights.org/donate target=&quot;_blank&quot;>Donate</a></li><li
data-section="newsletters">
<a
href="/newsletters" data-role="internal">Our Newsletters</a></li><li><a
href="#" class="toggle-search"><i
class="icon-search"></i></a></li></ul><div
class="nav-mini"><ul
class="current-section"><li
data-section="work"><a
href="/work" data-role="internal">Our Work</a></li><li
data-section="awards"><a
href="/awards" data-role="internal">Awards</a></li><li
data-section="news"><a
href="/news" data-role="internal">News</a></li><li
data-section="legacy"><a
href="/legacy" data-role="internal">Bobby</a></li><li
data-section="about"><a
href="/about" data-role="internal">About</a></li><li
data-section="donation"><a
href="/donation" data-role="internal">Donate</a></li><li
data-section="newsletters"><a
href="/newsletters" data-role="internal">Our Newsletters</a></li></ul>
<a
href="#" class="icon-menu toggle-menu"><div></div><div></div><div></div>
</a></div><div
class="gradient light"></div><div
class="gradient light-marquee"></div><div
class="gradient dark"></div><div
class="gradient dark-marquee"></div></div><div
id="subnav" class="tone-light"><div
class="subnav-content"><ul
class="nav-sections nav-standard clear"><li><a
href="https://rfkhumanrights.org/news" data-role="internal" class="active parent-active">News</a></li></ul></div></div><div
id="menu"><div
class="container-fluid"><div
class="row"><div
class="col-md-5"><div
class="nav"><ul
class="nav-menu"><li
data-section="work"><a
href="/work" data-role="internal">Our Work</a></li><li
data-section="awards"><a
href="/awards" data-role="internal">Awards</a></li><li
data-section="news"><a
href="/news" data-role="internal">News</a></li><li
data-section="legacy"><a
href="/legacy" data-role="internal">Bobby</a></li><li
data-section="about"><a
href="/about" data-role="internal">About</a></li><li
data-section="donation"><a
href=https://rfkhumanrights.org/donate target=&quot;_blank&quot;>Donate</a></li><li
data-section="newsletters"><a
href="/newsletters" data-role="internal">Our Newsletters</a></li></ul><ul
class="nav-submenu"><li><a
href="/search" data-role="internal">Search <i
class="icon-search"></i></a></li></ul></div></div><div
class="col-md-7"><div
class="menu-quote"><div
class="quote">Tame the savageness of man and make gentle the life of this world</div><div
class="quote-attribution">Robert F. Kennedy</div></div></div></div></div></div><div
id="layout"><div
id="content"><div
class="subcontent newspost" data-id="421695"><div
class="block block-marquee vert-compact tone-dark box-slanted " data-tone="dark" style=""><div
class="container-fluid "><div
class="row row-title"><div
class="col-md-10"><div
class="pretitle with-dash"><div
class="date">4.26.2021</div></div><div
class="title">Robert F. Kennedy Human Rights Partners With Skytop Strategies to Advance Its Corporate Accountability Work</div></div></div></div></div><div
class="block block-text-standard with-sidebar tone-light" data-tone="light"><div
class="container"><div
class="row"><div
class="col-md-7"><div
class="dash-title headline-standard">The new partnership will further extend RFK Human Rights’ global network, engaging a new community of business leaders on policies and practices that prioritize the public good.</div><p>Robert F. Kennedy Human Rights has announced it will be partnering with Skytop Strategies, a global integrated media firm with a content-driven platform that reaches a large community of corporate executives, institutional investors, NGO and government agencies, as well as other industry stakeholders around corporate strategy for the public good.</p><p>For over a decade, RFK’s <a
href="https://rfkhumanrights.org/work/compass" target="_blank">Compass Investors</a> program has convened a private network of institutional investors, fund managers, and investment consultants who oversee close to $7 trillion in assets under management. This influential network’s focus is on exploring investment approaches that actively consider human rights and good governance by prioritizing the “S” in ESG&mdash;both within their organizations and across the industry.</p><p>Building on the ongoing success of RFK Compass Investors, the new Skytop partnership is intended to expand the program’s community of decision-makers.</p><p>“As a human rights organization that regularly dialogues with the business and investment community, we’ve seen firsthand how the pandemic and recent protests have spurred companies to think about social justice causes like never before. It’s now time to turn those promises into action and true, meaningful progress,” said <strong>Michael Schreiber, chief operating officer for Robert F. Kennedy Human Rights</strong>. “We’re eager to work with Skytop to broaden our efforts, guiding the corporate sector on how it can, and must, actively uphold human rights in every facet of its business, whether that’s the labor and supply chain or a choice of who’s given a seat at the board room table.”</p><p>RFK Compass Investors’ drive to define the “S” in ESG, finds its focus in developing and promoting policies and practices that achieve positive social change: advocating for and protecting the <strong>rights of workers </strong>in the global supply chain; <strong>promoting equity</strong>, both in access to capital and access to career opportunities that promote diversity and ensure greater racial and economic equity; and championing <strong>technology sector accountability </strong>by ensuring that tech firms support human rights as they expand their products and platforms.</p><p>“Global companies, institutional investors, and stakeholders are coming to our conferences and news platform with questions on how to manage the complexities of human rights risk. As regions globalize, it is apparent that companies wield influence and often serve as the arbiters of social change, be it in Bethesda or Botswana,” said<strong> Christopher P. Skroupa, founder and CEO of Skytop.</strong> He adds, “Robert F. Kennedy Human Rights is a highly sought-after partner because it reflects the legacy of our nation’s beloved human rights champion and believes that where the capital goes, the change flows. We connect others to engage, discover, and apply best practices to push through to deliver on the promise of opportunity for all.”</p><p>Skytop runs 25 conferences annually, has a presence in the U.S, Canada, the U.K., the Nordic Region, Europe, Israel and Asia, and is now launching Skytop Online, its business intelligence and news platform.&nbsp;<br><br></p><p><strong><a
href="https://rfkhumanrights.org/" target="_blank"><u>Robert F. Kennedy Human Rights</u></a></strong> <br> We are a nonpartisan, not-for-profit organization that has worked to realize Robert F. Kennedy’s dream of a more just and peaceful world since 1968. In partnership with local activists, we advocate for key human rights issues&mdash;championing changemakers and pursuing strategic litigation at home and around the world. And to ensure change that lasts, we foster a social-good approach to business and investment and educate millions of students about human rights and social justice.</p><p><strong><u><a
href="https://skytopstrategies.com/" target="_blank">Skytop Strategies</a><br></u></strong>Founded in 2014, Skytop is recognized as a consummate connector, bringing corporate leaders together with capital sources, solutions providers, and partners around the world, focusing on disruptive change and winning against it. We ignite new business relationships, keeping corporate leaders current on challenges of the moment through live, high-powered, thought leadership conferences, with a focus on Shareholder Activism, CSR/Sustainability, Global Affairs, Capital Markets, Investment Management and Cyber Security.&nbsp;&nbsp;</p></div><div
class="col-sidebar col-md-4"><div
class="items headline-standard"><div
class="item-sidebarText textstyle-standard"><div
class="dash-title">Contact</div><div
class="text"><p>Minhee Cho<br>Media Relations&nbsp;Associate<br><a
href="mailto:mcho@rfkhumanrights.org" target="_blank">mcho@rfkhumanrights.org</a></p></div></div><div
class="item-sidebarLink style-standard">
<a
href=https://rfkhumanrights.org/newsletters data-role=internal class="link">Subscribe to our newsletters<span
class="arrow">&nbsp;<i
class="icon-din-arrow-ne"></i></span></a></div><div
class="item-sidebarLink style-standard">
<a
href=https://rfkhumanrights.org/donate target=_blank class="link">Support our cause<span
class="arrow">&nbsp;<i
class="icon-din-arrow-ne"></i></span></a></div><div
class="item-sidebarSocialLinks"><div
class="slant"><i
class="icon-slant"></i></div><div
class="text"><div
class="title">Follow Us</div><div
class="icons">
<a
href="https://www.facebook.com/RFKHumanRights/" target="_blank"><i
class="icon-facebook"></i></a>
<a
href="https://twitter.com/RFKHumanRights" target="_blank"><i
class="icon-twitter"></i></a>
<a
href="https://www.instagram.com/rfkhumanrights" target="_blank"><i
class="icon-instagram"></i></a>
<a
href="https://www.youtube.com/user/RFKcenterComm" target="_blank"><i
class="icon-youtube"></i></a></div></div></div></div></div></div></div></div></div></div><div
id="footer" class="clear">
<a
href="/" class="logo" data-role="internal"><img
src="/img/logo-rfkhr-light.png" alt="Robert F. Kennedy Human Rights"></a><ul
class="nav"><li
data-section="work"><a
href="/work" data-role="internal">Our Work</a></li><li
data-section="awards"><a
href="/awards" data-role="internal">Awards</a></li><li
data-section="news"><a
href="/news" data-role="internal">News</a></li><li
data-section="legacy"><a
href="/legacy" data-role="internal">Bobby</a></li><li
data-section="about"><a
href="/about" data-role="internal">About</a></li><li
data-section="donation"><a
href=https://rfkhumanrights.org/donate target=&quot;_blank&quot;>Donate</a></li><li
data-section="newsletters"><a
href="/newsletters" data-role="internal">Our Newsletters</a></li></ul><div
class="icons">
<a
href="https://www.facebook.com/RFKHumanRights/" target="_blank"><i
class="icon-facebook"></i></a>
<a
href="https://twitter.com/RFKHumanRights" target="_blank"><i
class="icon-twitter"></i></a>
<a
href="https://www.instagram.com/rfkhumanrights/?hl=en" target="_blank"><i
class="icon-instagram"></i></a>
<a
href="https://www.youtube.com/user/RFKcenterComm" target="_blank"><i
class="icon-youtube"></i></a>
<a
href="https://www.linkedin.com/company/robert-f--kennedy-center-for-justice-and-human-rights/" target="_blank"><i
class="icon-linkedin"></i></a></div><div
class="copyright">&copy;2021 Robert F. Kennedy Human Rights / All Rights Reserved</div></div></div><div
id="menu-wipe">
<img
src="/img/logo-blank-dark.svg"></div> <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script><script src="/js/lib/jquery.royalslider.min.js"></script><script src="/js/lib/jquery.touchcarousel.min.js"></script><script src="/js/lib/jquery.magnific-popup.min.js"></script><script src="/js/lib/velocity.min.js"></script><script src="/js/lib/isotope.pkgd.min.js"></script><script src="/js/main.js?v=2020070801"></script> </body></html>